Riddled TV Repair Forum
Service Menu and Manual Schematics
 
   
 FAQFAQ   SearchSearch   RegisterRegister 
   Log inLog in 
Philips 42PF7321D/37 plasma HDTV. No picture or sound.    
Post new topic   Reply to topic    Riddled TV Repair Forum Index -> TV Repair
 
Author Message
rx7351w



Joined: 24 Aug 2008
Posts: 3

PostPosted: Sun Aug 24, 2008 11:49 pm    Post subject: Philips 42PF7321D/37 plasma HDTV. No picture or sound. Reply with quote

Philips 42PF7321D/37 plasma HDTV. No picture or sound.

Hi I just found your message board while searching for help. I have/had no picture or sound. When it first stopped working the green LED would go out and the red LED would flash 4 times. I searched Philips.com and found a new firmware and installed it (ver. EX11U-1.5.0.0_09 28/11/2006 6:30:39). Now when I turn it on it just has a solid green LED. When I turn it on I hear a relay click (green LED's #8001, 8002, 2010 light up in the middle of the back, 5 seconds later it clicks again and the LED's go out. I haven't taken the back cover off yet. It looks like there are 2 boards in the middle both with 2 LED's each and one board down lower with a LED. The lower board LED stays on while it is plugged in and off.

Now that it is working there is a flashing LED #2011 on board #PBA NO:LJ92-01270A/B/C/E/F/G/H/J/K/L/M Rev. LA2 that wasn't lighting/flashing before. After messing with it for most of the day plugging and unplugging it, powering it on and off it finally came on. When it came on it flickered dimly and then came on with a normal screen. Now that it's working I can turn it off and it comes back on but for how long I don't know.

Any idea on what I need to inspect or replace? Where can I find a service manual?

Thanks
Google

PostPost subject: Advertisement

rx7351w



Joined: 24 Aug 2008
Posts: 3

PostPosted: Mon Aug 25, 2008 8:52 pm    Post subject: Reply with quote

Here's some more info.

It started working last night after messing with it all day. This morning it wouldn't turn on.

+Plug in red led on front flashes once then changed to green then it goes out. hit power button clicks green led on 5 seconds later clicks again with no picture or sound green led still on.

+When I unplug the power the red led flashes for a second.

+Plug in click upper and lower led's light up, clicks 5 sec. later and the upper led's go out. led 2011 never flashed. green led on front was on, never hit power button. red led flashed once on front after it was unplugged.

+turned on (never unplugged power cord) lower led's on and front green led on, no clicks or upper led's.

I'll pull the back cover off in the next couple days to get led numbers.

Thanks again
jasont2282



Joined: 20 Jul 2009
Posts: 1
Location: pa

PostPosted: Mon Jul 20, 2009 8:42 pm    Post subject: I have the Same problem Reply with quote

Phillips 42 PBA REV LA2 light comes on then shuts off. Were you able to fix this? If you did can you please let me know whatt you did
rx7351w



Joined: 24 Aug 2008
Posts: 3

PostPosted: Mon Jul 20, 2009 9:26 pm    Post subject: Reply with quote

I never fixed it. I was quoted $500 so I replaced it with a new vizio
Display posts from previous:   
Post new topic   Reply to topic    Riddled TV Repair Forum Index -> TV Repair All times are GMT - 6 Hours
Page 1 of 1

 


Disclaimer: All information provided by RiddledTV is strictly for information purposes only. Please observe all warnings displayed on your electronic
devices. This information should only be used to help diagnose work, and all service should be performed by a qualified technician.
Privacy Policy       Copyright © 2020 RiddledTV.com       Advertise on RiddedTV.com