Riddled TV Repair Forum
Service Menu and Manual Schematics
 
   
 FAQFAQ   SearchSearch   RegisterRegister 
   Log inLog in 
Sony KP-61HS10 Replaced ICs; Still has Bad Picture    
Post new topic   Reply to topic    Riddled TV Repair Forum Index -> TV Repair
 
Author Message
SailorJerry



Joined: 27 Jan 2010
Posts: 6

PostPosted: Fri Jan 29, 2010 11:19 am    Post subject: Sony KP-61HS10 Replaced ICs; Still has Bad Picture Reply with quote

I have a Sony KP-61HS10 when I first turn the tv on the, picture is scrambled and if I leave the tv on for about 20-30 minutes it will clear up and when I hit flash focus the picture comes in nearly perfect. Although after the picture comes in nice and focused and I bring up the tv menu and the menu is jittery but the program on tv is not jittery. So I thought that this was a convergence issue so I replaced the convergence chips but, the tv is doing the same thing after the ICs where replaced. So I am thinking that there are some resistors and or capacitors that still need to be replaced. Does anyone know which ones need to be replaced or what the problem could be still?

The ICs that I put in it are STK392-040

Thanks!
Google

PostPost subject: Advertisement

kuhurdler



Joined: 28 Dec 2006
Posts: 2879
Location: Overland Park, KS

PostPosted: Fri Jan 29, 2010 11:29 am    Post subject: Reply with quote

looks like vertical circuit problem to me.
SailorJerry



Joined: 27 Jan 2010
Posts: 6

PostPosted: Fri Jan 29, 2010 12:03 pm    Post subject: Reply with quote

Im not real familiar with televisions what does that mean or how could it be fixed?
kuhurdler



Joined: 28 Dec 2006
Posts: 2879
Location: Overland Park, KS

PostPosted: Fri Jan 29, 2010 1:17 pm    Post subject: Reply with quote

nevermind, it can't be the vertical if the OSD (on screen display) is showing
SailorJerry



Joined: 27 Jan 2010
Posts: 6

PostPosted: Fri Jan 29, 2010 3:04 pm    Post subject: Reply with quote

Do you think it could possibly be a resistor or fuse bad after replacing the ICs? I checked the fuses with a multimeter on the ohms setting and it gave me a small amount of resistance meaning that they are good is that correct?

Thanks
Google

PostPost subject: Advertisement

Display posts from previous:   
Post new topic   Reply to topic    Riddled TV Repair Forum Index -> TV Repair All times are GMT - 6 Hours
Page 1 of 1

 


Disclaimer: All information provided by RiddledTV is strictly for information purposes only. Please observe all warnings displayed on your electronic
devices. This information should only be used to help diagnose work, and all service should be performed by a qualified technician.
Privacy Policy       Copyright © 2020 RiddledTV.com       Advertise on RiddedTV.com