Riddled TV Repair Forum
Service Menu and Manual Schematics
 
   
 FAQFAQ   SearchSearch   RegisterRegister 
   Log inLog in 
Vizio VP50HDTV10A Plasma No Power    
Post new topic   Reply to topic    Riddled TV Repair Forum Index -> TV Repair
 
Author Message
nobbyv



Joined: 08 Nov 2009
Posts: 3
Location: NH

PostPosted: Sun Nov 08, 2009 8:40 am    Post subject: Vizio VP50HDTV10A Plasma No Power Reply with quote

Picked up the 50" plasma set above for short money. Trying to get it running. The issue is there is NO power of any kind. Plugging in the cord causes the two relays on the power supply board to cycle a few times, but that's it. No LEDs either internally or externally, nothing. Does nothing when power button pressed.

Previous owner replaced power supply board, no difference. Have checked all fuses, including SMT fuses. No obvious signs of a failing cap (bulging tops, etc).

I am pretty handy and would like to take a shot at this one. Anyone have any ideas?

Thanks!
Google

PostPost subject: Advertisement

Display posts from previous:   
Post new topic   Reply to topic    Riddled TV Repair Forum Index -> TV Repair All times are GMT - 6 Hours
Page 1 of 1

 


Disclaimer: All information provided by RiddledTV is strictly for information purposes only. Please observe all warnings displayed on your electronic
devices. This information should only be used to help diagnose work, and all service should be performed by a qualified technician.
Privacy Policy       Copyright © 2020 RiddledTV.com       Advertise on RiddedTV.com